About This Site

This site is designed to give you a top level view of any outage that may occur on the Simple Servers network. The page will update automatically with no need for a browser refresh. Further updates will also be posted on twitter @simplehostinguk

19th April 2016

Shared Hosting Shared Victor Server

We are currently investigating connectivity issues with shared VICTOR server

Update (08:48): We are seeing intermittent packet loss and are investigating and high load
Update (09:35): The issue has been isolated and the server is performing normally