About This Site

This site is designed to give you a top level view of any outage that may occur on the Simple Servers network. The page will update automatically with no need for a browser refresh. Further updates will also be posted on twitter @simplehostinguk

25th May 2016

Shared Hosting Shared Server Hybrid 6

We are currently investigating connectivity issues with shared Hybrid 6 server

Update (09:48): We are investigating issues server load
Update (10:07): Issue resolved large connections to a customers account from an IP has been mitigated