About This Site

This site is designed to give you a top level view of any outage that may occur on the Simple Servers network. The page will update automatically with no need for a browser refresh. Further updates will also be posted on twitter @simplehostinguk

26th May 2016

Emergency Cloud Network Upgrade

We are currently implementing a critical cloud network patch. Some VM may experience partial outages

Update (20:45): We are working on the upgrade, update shorty
Update (22:05): We are experiencing some issues on certain HV and are working to a resolution
Update (22:20): Network update successful all VM back online