About This Site

This site is designed to give you a top level view of any outage that may occur on the Simple Servers network. The page will update automatically with no need for a browser refresh. Further updates will also be posted on twitter @simplehostinguk

4th March 2016

Shared Hosting Shared Xray Server

We are currently investigating connectivity issues with shared Xray server

Update (09:10): An engineer is currently on site working on the server
Update (09:49): Resolved error on HDD 2, HDD replaced