About This Site

This site is designed to give you a top level view of any outage that may occur on the Simple Servers network. The page will update automatically with no need for a browser refresh. Further updates will also be posted on twitter @simplehostinguk

23rd March 2016

Shared Hosting Connectivity issue with Shared KILO Server

We are currently investigating connectivity issues with shared KILO server

Update (08:40): We are investigating the issue
Update (09:20): There was a high load on the server this has now been resolved.